رفتن به مطلب
iranwebserver میزبانی وب
soodi1100

مشکل به روزرسانی ووکامرس

پست های پیشنهاد شده

با سلام

بنده با آپدیت ووکامرس و ووکامرس فارسی مشکل دارم و هم اکنون از ووکامرس 3.3.3 و ووکامرس فارسی 3.3.0 استفاده میکنم که قدیمی هستند

با آپدیت ووکامرس با ارور 503 مواجه میشم و با آپدیت ووکامرس فارسی با ارور/public_html/wp-content/plugins/persian-woocommerce/include/class-gateways.php مواجه میشوم

متشکر میشوم که کمکم کنید

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

@soodi1100 با بروز رسانی ووکامرس خیلی از فایل ها تغییر کردن
و شما علاوه بر پلاگین ووکامرس یک فولد ووکامرس هم در قالب سایتتون دارید
اگه دسترسی به ورژن جدید قالب سایتتون دارید فودر ووکامرس موجود توی تم رو جایگزین قالبی که الان فعال هست بکنید احتمال زیاد مشکلتون حل خواهد شد.

اگه با این کار مشکل حل نشد لطفا توی همین پست اعلام بفرمایید

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

سلام

تشکر از پاسختون

من قالبم zephyr هست و توی فایل های قالب فایل plugins-support رو باز کردم ولی ووکامرس نبود داخلش که خودم کپی کردم و تغییری نکرد همچنان ارور 503 هست ولی توی همون فایل های قالب یه فایل دیگه به نام framework بود که داخل اون هم یه پوشه plugins-support دیگه بود و داخلش پوشه woocomerce هم بود ولی توی پوشه فقط دوتا فایل یکی header-shop.php و یکی woocommerce.php بود که با جایگزین کردن woocommerce.php جدید و یا کلا جایگزین کردن فایل ووکامرس جدید با ارور زیر مواجه میشم

Fatal error: Cannot redeclare wc() (previously declared in /home3/elecroni/public_html/wp-content/plugins/woocommerce/woocommerce.php:38) in /home3/elecroni/public_html/wp-content/themes/Zephyr/framework/plugins-support/woocommerce/woocommerce.php on line 39

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

@soodi1100 نه اصلا نیاز نبوده به این کارها
شما فقط باید نسخه ی ووکامرس قالب رو با نسخه پلاگین ووکامرست یکی بکنی

برای اینکار اگه میتونی از آخرین قالب زفایر استفاده کن و به عنوان یک قالب تستی به وردپرست اضافش کن و پیوند های یکترو بعدش مجدد ذخیره بزن ومورد رو بهمون خبر بده
در ضمن آدرس سایتتون رو هم لطفا بفرستید

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

سلام

قالب نال شده رو هم نصب کردم ولی باز هم با آپدیت ارور زیر رو میده

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home3/elecroni/public_html/wp-content/plugins/persian-woocommerce/include/class-gateways.php on line 54

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

با سلام دوست عزیز

برای فعال کردن و بروزرسانی باید چند نکته مهم رو بررسی کنید

اولا نسخه وردپرس باید به ورژن 4.9.7 و این یعنی مهمترین بخش بروزرسانی .

دوم نسخه php سمت سرور است که باید به 7 یا بالاتر 7.2 تغییر کند .

سوم قالب باید با وردپرس و وکامرس مورد نظر کاملا هماهنگ باشد یعنی بروزرسانی شده باشد .از این قالب دو نسخه در فضای مجازی هست یکی نسخه که کلا بروزرسانی ندارد و دیگری که سازنده آن UpSolution  است آخرین بروزرسانی اش این است

Version 4.10.2 — January 3, 2018 #

FIXED security issue, which can be potentially used by logged-in users in admin pages

این قالب تا نسخه 3.4.3 بروز هست و نسخه 3.4.4 هنوز بروزرسانی نشده انگار.

مشکلی هم که شما عنوان کردید مرتبط با افزونه پرشین وکامرس هست یعنی شما باید اول افزونه را غیر فعال کنید ضمن اینکه نسخه 3.4.2 با نسخه 3.4.4 هماهنگ هست .

شما به نکات مطرح شده دقت کنید مشکلتون رفع میشه

موفق باشید

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

برای ارسال دیدگاه یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید دیدگاهی ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در سایت ما ثبت نام کنید. عضویت خیلی ساده است !

ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید

ورود به حساب کاربری

×