آموزش بروزرسانی بسته فارسی ساز ووکامرس از 2.3.8 به نسخه های جدیدتر

وضعیت
موضوع بسته شده است.

Mohammad

مدیر انجمن
عضو کادر مدیریت
6/4/08
15,317
261
83
31
PersianScript
در صورتی که از بسته فارسی ساز 2.3.8 و قدیمی تر استفاده می کنید ، در هنگام بروزرسانی به نسخه های جدیدتر (2.3.9 و بالاتر) با مشکل عدم اجازه انتخاب شهر در صفحه تسویه حساب و خطا روبرو می شوید

برای رفع این مشکل مراحل زیر را به ترتیب انجام دهید:

  1. ابتدا به بخش مدیریت افزونه ها رفته و افزونه "ووکامرس فارسی" را غیر فعال کنید
  2. مجددا به بخش مدیریت افزونه ها رفته و این بار افزونه "Woocommerce" یا "ووکامرس" (هسته ووکامرس) را غیر فعال کنید
  3. در نهایت به بخش مدیریت افزونه ها رجوع و ابتدا افزونه "Woocommerce" یا "ووکامرس" (هسته ووکامرس) را فعال و سپس بسته فارسی ساز ووکامرس را با نام "ووکامرس پارسی" را فعال کنید
نکته
تمامی این مراحل باید به ترتیب اعمال شود
چون نسخه جدید در حالت آزمایشی می باشد در صورتی که مشکل خاصی در هنگام بروزرسانی مشاهده کردید در همین تاپیک اعلام کنید.

از همکاری شما سپاسگذاریم

 

نیما صابری

تازه وارد
24/8/08
18
0
1
30
http://ideyeno.ir
ضمن تشکر

مشکلی نداشتم، اما کاری که در آموزش هست رو انجام دادم

فقط این پیام با توجه به اینکه دکمه کلوز نداره تا چه زمانی در ادمین وردپرس نمایش داده میشه ؟

برای تکمیل بروزرسانی بسته فارسی ساز ووکامرس لطفا راهنما را مطالعه نمایید.  .

 
 

hannanstd.ir

مدیر انجمن و توسعه دهنده ووکامرس پارسی
27/9/12
3,477
3
38
لنگرود
دوستان مشکلات زیر رفع شده :

سفید شدن صفحه رفع شده .

اینکه بعد از بروز رسانی باید اول بسته فارسی ساز رو غیرفعال کنید و بعد فعال کنید هم رفع شده .

اینکه اول بسته فارسی ساز فعال باشه یا ووکامرس هم رفع شده و مهم نیست که کدوم اول فعال باشه یا نباشه ...

با توجه به اینکه شهر های ایران در نسخه بتا هست ، اضافه شدن شهر های ایران هم اختیاری شده و به صورت پیش فرض غیرفعال هست که هر کسی تمایل داشت میتونه فعالش کنه .

اینکه حتما باید منطقه زمانی رو تهران باشه تا زبان فارسی اضافه بشه هم رفع شده .

تا چند ساعت آینده منتشر میشه .

 
آخرین ویرایش توسط مدیر:

98cell.ir

کاربر عضو
2/12/13
470
0
16
25
با توجه به اینکه شهر های ایران در نسخه بتا هست ، اضافه شدن شهر های ایران هم اختیاری شده و به صورت پیش فرض غیرفعال هست که هر کسی تمایل داشت میتونه فعالش کنه .
دادا دمت گرم

اینو از کجا فعال کنیم؟

توی این فارسیساز وقتی میخوایم تغییر وضعیت بدیم و تاریخ میخواد

تقویمه ک باز میشه نصفش نیست

:63:

 

hannanstd.ir

مدیر انجمن و توسعه دهنده ووکامرس پارسی
27/9/12
3,477
3
38
لنگرود
دادا دمت گرم

اینو از کجا فعال کنیم؟

توی این فارسیساز وقتی میخوایم تغییر وضعیت بدیم و تاریخ میخواد

تقویمه ک باز میشه نصفش نیست

:63:
دوست عزیز مشکلی توی تغییر وضعیت و تاریخ وو ... که وجود نداره . این گزینه هم صبر کنید بروز رسانیش بیاد نوشتیم چه طوری فعال میشه .

 

meysam1987

تازه وارد
28/8/14
18
0
1
تهران
سلام

پیغام زیر بعد از بروزرسانی دایم بالای صفحه است

"برای تکمیل بروزرسانی بسته فارسی ساز ووکامرس لطفا راهنما را مطالعه نمایید.  ."

چرا نمیره؟

 

xaniar.zaer88

تازه وارد
31/5/15
3
0
1
سلام و خداقوت.

مشکلاتی که گفتید رفع شده به جز چیزی که مد نظر من بود.

می خوام انتخاب شهر به صورت دستی باشه و دستی وارد بشه.

وقتی و.پ فعال می شه، حتما باید شهری رو انتخاب کنیم و نمی شه شهری رو وارد کرد.

الان خیلی از شهر ها تو لیست نیست از جمله شهری که خودم دارم توش فعالیت می کنم.

نسخه ی فعلی و.پ هم 2391 هست

 

hannanstd.ir

مدیر انجمن و توسعه دهنده ووکامرس پارسی
27/9/12
3,477
3
38
لنگرود
دوست عزیز گفتیم که منتظر بمونید تو نسخه جدید به صورت اختیاری شده . یعنی شما بعنوان مدیر سایت میتونید اصلا ازشهرهای اضافه شده استفاده نکنید و مثل قبل از شهرها استفاده کنید .

 

98cell.ir

کاربر عضو
2/12/13
470
0
16
25
دوست عزیز مشکلی توی تغییر وضعیت و تاریخ وو ... که وجود نداره . این گزینه هم صبر کنید بروز رسانیش بیاد نوشتیم چه طوری فعال میشه .


آخه یک آپدیتم دیشب ازین فارسیساز اومد ما فکر کردیم اونه....

 

Zyro

تازه وارد
سلام. آقا ممنون از خبر. اما برای من کار نمیکنه. دقیقا از همین راهی که گفتید رفتم ولی وقتی استانی رو انتخاب میکنی شهری نمیاد. حالا اگر یک استان دیگه رو انتخاب کنی تازه شهر های استان قبلی میان. لطفا زود پیگیری کنید!

ممنون

 

Mohammad

مدیر انجمن
عضو کادر مدیریت
6/4/08
15,317
261
83
31
PersianScript
نسخه جدید منتشر شد. دوستان بروزرسانی کنید

وجود شهر ها ، انتخابی شد.

 

نیما صابری

تازه وارد
24/8/08
18
0
1
30
http://ideyeno.ir
سلام

ممنون بابت بروز رسانی ؛ پیام آزاردهنده ای که توی ادمین بود خداحافظی کرد ...

فقط دو سری مشکل هست ؛

اول تداخل replacetext.php افزونه ووکامرس فارسی با افزونه easy watermark :

You must be registered for see images attach


این مشکل فکر میکنم مربوط به لاین 10  به بعد replacetext باشه که نیاز به بازنویسی بر اساس داکیومنت زیر داره :



دوم ارور زیر :

Use of undefined constant WPLANG - assumed 'WPLANG ؛

You must be registered for see images attach


که با تغییر لاین 55 فایل woocommerce-persian.php رفع میشه :

کد:
		if ( $this->language == null ) {			//$this->language = get_option( 'WPLANG', WPLANG );			define ('WPLANG', '');			$this->language = (defined(WPLANG) && WPLANG != '' ? WPLANG : 'en_US');			$this->is_persian = ( $this->language == 'fa' || $this->language == 'fa_IR' );		}
 

pouriahector

تازه وارد
31/5/15
11
0
1
نسخه 2.9.1 ارور .rtl میداد و در 2.9.2 رفع شده این افزونه چرا انقدر باگ داره؟؟!

 

Mohammad

مدیر انجمن
عضو کادر مدیریت
6/4/08
15,317
261
83
31
PersianScript
سلام

ممنون بابت بروز رسانی ؛ پیام آزاردهنده ای که توی ادمین بود خداحافظی کرد ...

فقط دو سری مشکل هست ؛

اول تداخل replacetext.php افزونه ووکامرس فارسی با افزونه easy watermark :



این مشکل فکر میکنم مربوط به لاین 10  به بعد replacetext باشه که نیاز به بازنویسی بر اساس داکیومنت زیر داره :



دوم ارور زیر :

Use of undefined constant WPLANG - assumed 'WPLANG ؛



که با تغییر لاین 55 فایل woocommerce-persian.php رفع میشه :

        if ( $this->language == null ) {            //$this->language = get_option( 'WPLANG', WPLANG );

            define ('WPLANG', '');

            $this->language = (defined(WPLANG) && WPLANG != '' ? WPLANG : 'en_US');

            $this->is_persian = ( $this->language == 'fa' || $this->language == 'fa_IR' );

        }
ممنون. در نسخه بعدی (طی همین روز ها) حتما اعمال می کنم.

نسخه 2.9.1 ارور .rtl میداد و در 2.9.2 رفع شده این افزونه چرا انقدر باگ داره؟؟!
باگ مورد طبیعی هست

ضمن اینکه در نسخه 2.9 روی چند هاست تست کردیم مشکلی نبود. اما برخی یوزر ها مشکلاتی رو داشتند که مجبور به بروزرسانی مجدد شدیم

 

نیما صابری

تازه وارد
24/8/08
18
0
1
30
http://ideyeno.ir
در نسخه بعدی (طی همین روز ها) حتما اعمال می کنم.
این مورد هم هست :

has_cap از نگارش 2.0 از رده خارج شده! استفاده از سطوح دسترسی کاربران توسط افزونه‌ها و پوسته‌ها از رده خارج شده است. از نقش‌های کاربری و توانایی‌ها به‌جای آن‌ها استفاده کنید.

You must be registered for see images attach


 

hamidtm

تازه وارد
1/6/15
11
0
1
سلام

مشکل اکسترکت داره بسته فارسی ساز جدید و همین طور هسته اصلی

چه کار باید کرد؟

 
وضعیت
موضوع بسته شده است.