اشتباه نشان دادن تعداد محصولات توسط لایه کنترل ووکامرس (صفت ها)

sahand11_m27

تازه وارد
5/10/14
7
0
1
سلام

امروز متوجه دو مشکل در سایت شدم.

1- من یک صفت ساختم برای برند کالا. و بوسیله لایه کنترل ووکامرس در ساید بار تعداد محصولات یک برند نمایش داده میشه. ولی این تعداد اشتباه است. این مشکل بعد از آپدیت ووکامرس و وردپرس بوجود اومده. یعنی شما وارد بخش فروشگاه که میشید، مثلا تعداد محصولات نایک و آدیداس رو 20 تا نشون میده در صورتی که 40 تا هستند. پیشنهادی دارید که ممکنه مشکل ار کجا باشه؟

مشکل بعدی هم در همین رابطه هستش. وقتی محصولات را مثلا با برند نایک صافی می کنید، 2 صفحه محصول وجود خواهد داشت. در صفحه ی اول همه چیز درسته ولی وقتی صفحه عوض میشه، صافی هم ریست میشه و دیگه تمام محصولات نشون داده میشه و فقط محصولات نایک نمایش داده نمیشه. دقیقا وقتی که از صفحه ی اول میریم به صفحه ی دوم این مشکل ایجاد میشه.

 

.exe

کاربر عضو
13/7/14
160
1
16
سلام ؛

قالبتون با نسخه جدید ووکامرس سازگاری نداره ، صفحات رو دوباره ایجاد کنید ببینید مشکلتون رفع میشه ؟

این آموزش رو هم بخونید :


کد:
http://forum.persianscript.ir/f137/%D8%A2%D9%85%D9%88%D8%B2%D8%B4-%D8%B3%D8%A7%D8%B2%DA%AF%D8%A7%D8%B1-%DA%A9%D8%B1%D8%AF%D9%86-%D9%BE%D9%88%D8%B3%D8%AA%D9%87-%D9%82%D8%AF%DB%8C%D9%85%DB%8C-%D8%A8%D8%A7-%D9%86%D8%B3%D8%AE%D9%87-%D8%AC%D8%AF%DB%8C%D8%AF-%D9%88%D9%88%DA%A9%D8%A7%D9%85%D8%B1%D8%B3-16013/
اسم قالبتون رو هم ذکر کنید .

 

sahand11_m27

تازه وارد
5/10/14
7
0
1
سلام

ممنون از پاسختون

من از انفولد استفاده می کنم. دیروز به آخرین نسخه ی منتشر شد ورژن 3.0.1 اپدیت کردم. توی اون پست آموزشی، مشکلی که ذکر شده بود رو سایت من گویا نداره و اروری من ندیدم. ارور قرمز رنگی هم وجود نداره.

بازنویسی*های قالب:هیچ جایگزینی هسته*ای در قالب وجود ندارد

تا چند دقیقه پیش وقتی روی یکی از صفتها کلیک میکردم به قسمت بلاگ هدایت می شد سایت. بعد از اون از قسمت پیوندهای یکتا، پایگاه صفت*های محصول رو عوض کردم، الان وقتی روی یک صفت مثل نایک کلیک میکنم یکی از محصولات نایک رو باز میکنه.

/attribute-name/attribute/

حالا فکر کنم از اون آموزشی که فرستادید ضرری نداشته باشه کل پوشه رو با بک آپی که از نسخه آخری که کار می کرد جایگزین کنم

 
آخرین ویرایش توسط مدیر:

sahand11_m27

تازه وارد
5/10/14
7
0
1
مشکل با عوض کردن اسم صفت و اسلاگ اون حل شد. احتمالا مشکلی با حروف فارسی داشته. اسم و اسلاگ رو به حروف انگلیسی Brands تغییر دادم و حل شد مشکل.